Создание сборки сервера на FORGE
  • NoName

    12 сентября 2022 - 19:40
    Вы не авторизованы, войдите на сайт.
  • просмотров 898 | ответов 59
Решили создать сервер на моем пк, процедура стандартная, фордж правильной версии, install server и тд. Вот только проблема, не знаю, какие папки из клиента нужно копировать в папку сервера чтобы все работало + как сделать нормальный батник для запуска сервера, а то у меня вылазит ошибка, помню на этом форуме помогли, но не объяснили чтобы снова не обращаться сюда, буду благодарен кто поможет. https://www.curseforge.com/minecraft/modpacks/create-above-and-beyond
  • Алексей
    Алексей
    14 сентября 2022 - 00:08
Не-а не работает, давайте обменяемся дискордом? Так будет удобнее разбираться + мне сейчас уже нужно уходить
Пишите сюда в любое время, я отвечу.
  • NoName

    14 сентября 2022 - 00:11
Понял, спасибо, тогда до завтра, пока у самого идей нету, как починить
  • Алексей
    Алексей
    14 сентября 2022 - 00:13
Понял, спасибо, тогда до завтра, пока у самого идей нету, как починить
Вы сборку запакуйте в архив и скиньте на яндекс диск. Так быстрее получится разобраться, если я её скачаю и посмотрю.
  • NoName

    14 сентября 2022 - 12:25
Здравствуйте! Вот https://disk.yandex.ru/d/q87N322U78iRwQ
  • Алексей
    Алексей
    14 сентября 2022 - 13:44
Здравствуйте!
Это же файлы игрового клиента.
Вам нужно из них взять только моды.

Launching target 'fmlserver' with arguments [--gameDir] Exception in thread "main" [main/INFO] [STDERR/]: [java.lang.ThreadGroup:uncaughtException:-1]: java.lang.NoSuchMethodError: sun.security.util.ManifestEntryVerifier.<init>(Ljava/util/jar/Manifest;)
Версия forge-1.16.5-36.2.20 работает только на самых первых билдах Java 8. Вам нужно либо новее Forge использовать, любо найти самую первую версию Java8, до обновлений.
  • NoName

    14 сентября 2022 - 14:39
Есть сайты с архивами java, можно этот попробовать, только неизвестно насколько это безопасно. Кстати, нашёл эту ссылку на форуме forums.minecraftforge.net, иностранцы её друг другу там рекомендуют.
  • NoName

    14 сентября 2022 - 14:52
Ага, понял, только в одиночном мире фордж работает стабильно, почему для сервера нужно скачивать более старую версию?
  • NoName

    14 сентября 2022 - 14:57
Ага, понял, только в одиночном мире фордж работает стабильно, почему для сервера нужно скачивать более старую версию?
Потому, что люди как и вы столкнулись с данной проблемой, и единственное решение которое они нашли — это было решение понизить версию JAVA. Forge клиент и forge сервер — это как бы не одно и тоже.
  • NoName

    14 сентября 2022 - 16:15
Ок! Понял, то есть удалить 8 джаву и поставить более старую и уже на нее указать путь
  • NoName

    14 сентября 2022 - 16:18
На том сайте нету Джавы ниже 321.. Вижу только 322