Ошибка 22 мая 2016 - 18:06
Посетители, находящиеся в группе Гости, не могут оставлять комментарии.
Игорь Гуцу 22 мая 2016 - 10:36
Группа: Посетитель
Сообщений: 28
Регистрация: 24.06.2015

Доброго времени суток. У меня крашит сервер, при этом в логах я вижу вот это  -  Caused by: java.lang.IllegalAccessError: tried to access method com.earth2me.essentials.Essentials.getUser(Lorg/bukkit/entity/Player;)Lcom/earth2me/essentials/User; from class de.czymm.serversigns.hooks.EssentialsHook at de.czymm.serversigns.hooks.EssentialsHook.getNickname(EssentialsHook.java:22) at de.czymm.serversigns.parsing.command.ServerSignCommand.getFormattedCommand(ServerSignCommand.java:89) at de.czymm.serversigns.parsing.command.ServerSignCommand.getTasks(ServerSignCommand.java:138) at de.czymm.serversigns.signs.ServerSignExecutor.createCommandTasks(ServerSignExecutor.java:216) at de.czymm.serversigns.signs.ServerSignExecutor.executeSignFull(ServerSignExecutor.java:87) at de.czymm.serversigns.listeners.PlayerListener.playerInteractCheck(PlayerListener.java:60) at sun.reflect.GeneratedMethodAccessor165.invoke(Unknown Source) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.lang.reflect.Method.invoke(Method.java:498) at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.java:425) ... 17 more Кто то может объяснить, как можно это решить?

Влад Цилин 22 мая 2016 - 11:44
Группа: Администратор
Сообщений: 71
Регистрация: 1.01.1970

В ошибках говориться о плагинах serversign и Essentials. Для начала попробуйте установить плагины, подходящие под вашу версию minecraft. 

Марк SOBRZ 22 мая 2016 - 13:00
Группа: Посетитель
Сообщений: 1
Регистрация: 22.05.2016

Здравствуйте. При попытке запустить сервер на ядре mcpc+ мне выдаёт ошибку java 8 is not supported on MCPC+8.11? Pleas run MCPC+ using  java 7. Пожалуйста подскажите как исправить эту проблему.

Игорь Гуцу 22 мая 2016 - 14:46
Группа: Посетитель
Сообщений: 28
Регистрация: 24.06.2015

ВЛАД ЦИЛИН, спасибо, попробую.

Анатолий Денисов 22 мая 2016 - 18:06
Группа: Клиент
Сообщений: 1541
Регистрация: 1.01.1970

МАРК SOBRZ - На вашей локации установлена Java 8  а ваш MCPC+8.11 работает  видимо только со старыми версиями Java.

Выбрать