Фикс конфликта Authme с LuckPerms
  • Автар пользователя
    Referal
    23 октября 2020 - 17:38
    Вы не авторизованы, войдите на сайт.
  • 0 комментариев
 -------------------------------------------------------------------------------- Что делать, если не работают вместе два плагина: Authme с LuckPerms? Конфликтуют плагины: Authme и LuckPerms? Не работает - Authme с LuckPerms, как исправить? -------------------------------------------------------------------------------- Подобные вопросы у Майнкрафтеров возникают при загрузке и установке плагина LuckPerms, или перехода с плагина PermissionEx. Обычно неработоспособность сервера Майнкрафт при попытке совместного использования этих плагинов, сопровождается ошибкой в консоли:
[AuthMe] Aborting initialization of AuthMe: [InjectorReflectionException]: Could not invoke constructor of class 'class fr.xephi.authme.command.CommandHandler' [AuthMe] THE SERVER IS GOING TO SHUT DOWN AS DEFINED IN THE CONFIGURATION!
Как же решить данную проблему и подружить оба плагина, есть ли фикс? Решение: Ошибка возникает, если вы используете устаревшую версию плагина - обновите плагин: Authme. Если обновление не помогло, то следует выполнить действия, описанные ниже. Откройте конфигурационный файл находящийся в папке: /plugins/AuthMe/
Находим строчку: # Forces authme to hook into Vault instead of a specific permission handler system. Перевод этой строчки говорит о том, что если вы используете другой плагин разрешений, не PermissionEx, то в параметре: forceVaultHook: false, который чуть ниже этой строчки, следует вместо false, указать true. В итоге должно получится так: forceVaultHook: true